Piranha 8 Docs

Intro to Piranha

Piranha is a simple to use and fast GPU based compositing,
editing and color correction system. By using the speed of the
graphics card many of the operations that would require
rendering in other applications are handled very quickly in Piranha.

This document will walk you through the steps of installation,
loading of content, editing, color correcting and rendering your work.

Installation and Startup

Piranha supports both MacOSX (snow leopard and lion)
as well as a variety of 64bit Linux platforms.
This page will go over how to install on the platforms
and get started using Piranha.

Basics of Piranha Installation - How Piraha finds things

Piranha for the most part is self contained app that
can be installed anywhere on your system.
For OSX we usually recommend /Applications
for Linux it has traditionally been /usr/ifx/


Step 1. Download the Latest

The MacOSX version is available as a DMG download.

Step 2. Install the App

After downloading the latest dmg file via the site.
Double click and you should see the license agreement window
appear. After agreeing to the License you will have familiar
DMG drag and drop window. Simply drag the Piranha 7 Logo into
the Applications directory to install. You may also wish to then
double click the "Applications" directory and drag that Piranha 7
to the Dock.

While we are looking at the dock, make sure you have your Application
Dock setup to dissapear when the mouse moves away. (see known issues)

Step 3 Launch the App

To Launch the app double click the Piranha 7 icon.

Known OSX Issues and How to Fix them...

  • Piranha wont start when double clicked
  • A situation exists where double clicking the app causes it to hang.
    The best work around currently seems to be to run
    Piranha from a shell using the command:
    Hopefully fixed for next release.

  • Piranhas menu cant be reached
  • If the OSX Application Dock is not setup to dissappear, piranha
    uses too much screen space and is pushed out of view.
    Hopefully a fix but in the meantime make sure you have enabled
    the retractable dock in you OSX user prefs.

  • Prores Movies dont load
  • To read prores movies on OSX you will need the prores Quicktime components.
    These can be installed with final cut or there is an apple download here:

  • R3D files come in empty
  • If a corrupt R3D file is loaded, it can cause other R3D files to break
    for the app. Best solution, restart the app.

  • The lower case 'J' is not drawing on my menus.
  • We think its an openGL clipping issue with over-zelous descenders.
    Yes they are everywhere! For now choosing a different Display Font
    under Piranha Preferences should fix the issue.

    Installing and Launching Linux Piranha

    Step 1. Download the Latest

    The Linux version is available as a compressed tar file only.
    We dont like other stuff so dont ask. Okay that was a joke again.

    There are two versions for Linux, there is the Ubuntu 10.04 64bit compile
    and there is the Centos5 64bit compile. Generally if you are running a
    Linux distribution that was available more than 3 years ago you should
    use the Centos5 version. This will ensure you have the correct libraries installed.


    Step 2. Install the App

    After downloading the latest tgz file to your home directory.
    Open a shell and run the command:

    >tar xvzf piranha_linux_7.X.X.tgz
    >cd piranha_linux_7.X.X/

    If you wish to install the app (not necessary but gets you linux menus
    and a link to /usr/bin/piranha.

    >sudo ./INSTALL

    Step 3 Launch the App

    If you installed the app....
    To Launch the app you can choose Piranha
    from the Linux Launch Menu under Applications:Graphics.
    Or run it from the shell with the simple command: piranha.

    If you just untarred it you can run piranha from the command line:

    Known LINUX Issues and How to Fix them...

  • Quicktime Movies Dont Open
  • The Quicktime Library is needed on Linux.
    This can be installed on debian and ubuntu with the command:

    sudo apt-get install libquicktime1
    sudo ln -s /usr/lib64/libquicktime.so.1 /usr/lib64/libquicktime.so.0

    On Centos/RHEL/Fedora you will need to enable repositories
    and install via yum command:
    yum install quicktime

  • Redraw Seems Slow
  • Piranha needs OpenGL hardware drivers. In some cases (ubuntu/debian)
    you can enable these via the System preferences. In other cases you may
    need to download drivers.

  • Font Issue: strange or large display fonts
  • Some versions of Linux require the extra Xorg fonts to be loaded.

    For Debian/Ubuntu

    apt-get install xfonts-100dpi xfonts-75dpi

  • Font Issue: Menu Font is very large
  • Sometimes with monitors thats dont communicate EDID to linux
    correctly you will see large menu fonts in the app. This
    can be adjusted by going to Piranha's Preferences under Display
    and selecting a smaller menu font. (you can fix this with Xorg.conf,
    but thats much harder)

  • App wont run Centos 6 error regarding libcurl
  • Some diferences in Ubuntu vs Centos cause libcurl to go missing.

    libcurl-gnutls.so.4: cannot open shared object file: No such file or directory.

    You can create a link to it in either /usr/lib64 or /usr/ifx/piranha/lib64

    Piranha 8 Login and License Keys

    Logging onto the Piranha Cloud

    When you start the app for the first time it will
    ask for your login. During beta/eval you will need
    to be connected to the internet and have a valid
    eval account. If you have a permanent key you can
    skip to the section "Installing a License Key"

    To create a new account or change the password
    you can go to the Ifxsoftware Support URL at:

    Enter your username, and password. Note make sure you
    hit return after entering your password.

    Click 'Remember me' to have the system save your login information.
    Click 'Autologin' to have the system automatically log you in on startup.

    Installing a License Key

    If you have a license key from ifxsoftware you wish to install
    the easiest method is to simply copy the license line
    to your computer clipboard. When you run Piranha it should
    notice the key and open a dialog box.

    Once the key is installed you will need to restart the app.

    Starting a New Project

    When Piranha starts you should the Project Management Window
    below appear. This lets you quickly start a new Project
    or load a recently opened project.

    Choosing "New Project" will open the New Project dialog
    shown below. This will allow you to set some attributes
    about the project and also choose a directory for
    the project to be saved in.

    To choose a new directory for the projects you can click the
    '..' browse button. Piranha should remember the settings
    and directories when you exit the program.

    Opening an Existing Project

    Clicking on the 'Open Project' in the Project Manager will give you
    a choice of browsing for a file or you can simply click on one
    of the recently opened project.

    Basic App Layout

    By defualt the application will open in Edit mode. The current
    mode is indicated at the bottom of the applcation window.
    The other modes are "Effects" mode is where you can edit effect
    paramaters and arrange layers. "Graph" mode allows for curve
    editing of any animated parameters. The "Color" panel controls
    color correction.

    Getting some Content Loaded

    There are several ways to bring content into Piranha.
    The File->Import Menu provides the most common.

    Import Images will open a file browser based importer.
    The Clip bin described below allows more interactive browsing.

    Using the Clipbin and Loading Content

    To browse files and bring in some images
    the Clipbin can be opened by going to the menu item Tools->Clipbin.
    Its also available from the "File->Import->Use Clipbin" menu.

    To navigate to a particular directory you can click double click
    on a directory name (Previous Directory goes up one directory)
    or you can edit the path name shown at the top the clipbin window.
    You can make it easy to get back to the directory by clicking
    on the "Go" menu and choosing "Add Directory". This will permanently
    add the current directory to your "Go" menu.

    Supported file types, files which are loadable as sequences or
    single frames typically appear in the clip bin as a movie file icon.
    By clicking on the file with the middle mouse button you will
    get a preview jog window you can scroll though the clip with.
    When you release the mouse the first time, the file will get
    that frame as the icon. To replace an icon simply hold down
    control-key while releasing the middle mouse button. If you wish you can
    also click the "Build Icons" button at the top of the clipbin to
    have icons added to all the files in a directory.

    To bring a clip into the the timeline simply click and drag with
    the left mouse button and drop the icon onto either the canvas area
    (middle of the screen) or in the edit timeline.
    You can also drag a directory onto the canvas to import all the files
    as a timeline.

    Navigating between projects and desktop

    One of the really great features of the application
    is that you can have multiple projects open at one time.
    To see which projects are open and switch between them
    there is a project menu on the top right corner of the app.
    The first item in the menu is the Desktop and will allow you
    to switch to desktop view.

    Canvas and Viewing Controls

    The main canvas area is where content is displayed after importing.

    Panning and Zooming

    To pan click and hold the middle mouse button while
    the mouse is in the canvas area. Zooming can be done
    by holding the Alt key + middle mouse button.

    You can also zoom the time by using the Magnifying icons on the lower
    left of the canvas area. Fit and x1 controls offer a quick
    way to reset the view.

    Looking at Channels

    Individual channels of the RGB image can be viewed by toggling with the
    channel viewing mode menu next to the zoom controls.

    The View Menu

    The View menu provides some togglable modes for viewing.
    Proxy mode is especially useful for Red Camera users
    as the files have built in proxies for speeding computation and

    Grid controls drawing of a grid with snapping if needed.
    Color controls the color of the outlines used by the app
    (default is green)

    Use Crop to View to see parts of the image outside the setup cropped.

    Layer boarder, Action Safe, Title Safe and Center all turn on and
    off various boarders

    Using the Timeline

    The Piranha timeline is controlled from several places on the screen.
    The playback controls aka deck control are directly beneath the logo.
    The area to right of the playback controls is the jog shuttle area where
    you can click and drag to adjust the current frame.

    By default the app shows Frame numbers but one can also switch to timecode
    or even feet/frames. The timecode basis is decided by
    the current Project FPS (frames per second) as shown next to the playback
    deck control buttons.

    By clicking the middle mouse button and dragging in the jog shuttle area
    the timeline can be panned left and right.

    Holding down the Alt-Key and middle mouse dragging will
    scale the timeline. (note you may need to change your default window manager
    keyboard key. This can usually be found under "Windows" preference in the System
    Prefences menu of your Linux system.)

    The timeline can also be zoomed in and out and to fit by using
    the controls in the lower right corner of the app.

    Setting Marks

    Piranha has a simple way to mark frames via the Mark button on the main timeline
    and by the mark menu availble both then right clicking the frame job bar
    clicking and holding the mark button.

    Editing in Piranha

    Once there are some clips loaded into the system,
    you are ready to edit. To get started choose Edit mode
    from the Bottom of the application window.

    Navigating the Edit Timeline

    To pan the the timeline left and right use the middle mouse button.
    Like the main canvas Alt-middle mouse will zoom the time line.
    There are also several zoom controls which control the timeline in
    the lower right of the itnerface.

    Moving Clips Around

    To move one or more clips simple select them and then click in
    the middle of on of the clips to move the group.

    To adjust the edit point between two clips click and drag
    from the top point where the clips connect.

    Overwrite Mode

    When in "Overwrite" mode dragging clips onto
    other clips either overlays the destination clip or
    replaces it (replace mode)

    Ripple Mode

    Ripple mode causes a cut to be made and other clips
    moved to the right in time when a clip is
    dropped on the timeline.

    Cutting a Clip

    The Razor command can be used for cuting a clip.
    Usually this is bound to the 'r' key by default.
    The Razor All command does the same but will cut more than one

    Setting up Keyboard Controls

    Generally its a good idea setup your keyboard controls
    for Edit. The Bindings are availble from the File Menu Keyboard Config.
    (Choose the Edit panel)

    Accessing Functions from the Edit Menu

    Selected clips can also be affected by the commands available from
    the Edit menu. To access the menu, hold down the right mouse button
    over the edit interface.

    Adding Transitions

    When two clips overlap a transition is created.
    The default shown below is A over B. (ie no transition added)

    To add a dissolve select the first clip then type 'd'
    You will be prompted for the duration. Hit enter to accept.

    The clip show now show a 'D' and the transition line should now
    be diagonal.

    To change this to a wipe, again select the first clip then
    hit the 'w' key. (keys are configurable so check your setup)

    Effects such as wipe have some controls which can
    be adjusted from effects mode.

    Changing the Size of Edits and Icons

    One useful feature of the Edit timeline is the often missed
    timeline resizer. Click and drag the small thumbwheel above
    the scroll bar to increase the size of edits.

    Effects in Piranha

    Effects can be added to any selcted layer by going to the Add Effects menu
    and selecting an effect.

    adding effects

    To add an effect to a layer, highlight the layer name by clicking on it in the layer view and
    choose an effect from the Add Effect menu. The following chapters in this document give
    descriptions and usage of each effect.

    setting the current effect

    The interactive editing of many of Piranha’s effects is dependent on having the effect
    selected. You can do this by clicking on the effect name in the layer list, or by selecting the
    layer from the layout window pane, and then selecting the effect from the effect pane.

    rearranging and updating effects

    The order of effects is an important consideration when setting up a composite in
    Piranha. In many situations, image quality and effect predictability are dependent on the
    order in which the effects are processed. You can change the order of effects simply by
    clicking and dragging them in the layer list. Alternatively, effects can be moved around
    via the effects menu. Multiple effects can be selected for cut/copy/duplicate/paste/delete
    operations by holding the Shift key down and clicking each effect name; all currently
    selected effects will be highlighted.

    Effects can also be quickly toggled on and off via the calc/no calc (C) toggle button next to
    the effect name. This toggle can be quickly changed by positioning the mouse over the
    button and pressing the space bar.

    When toggling effects and stopped on a frame, the image won’t update until a refresh is
    triggered by the user. There a two ways to update new changes. The fastest is to simply
    click on the Piranha logo above the Layer list. This action only updates the current layer’s
    effects. The whole script may be updated by going to View>Update Now.

    Graphs and Channels

    Effect parameters can be edited and adjusted in several ways. For many
    parameters, simple integers or ?oating point values are the most intuitive way (as
    opposed to effects such as Primatte, which has a more complicated parameter input
    method.) These effects can be edited by the use of the input ?eld for the parameter. There
    are several modes for these types of parameters, which can be toggled by the input ?eld
    mode button (V/G/S toggle on every numerical parameter):

    Parameter Input Modes

    Parameter Value Mode (constant)

    When in value mode the parameter for an effect does not animate.
    Any new value input simply overrides the last value that was set.

    Parameter Graph Mode (animation)

    In this mode, you can easily set up different values at different
    frames, and Piranha will interpolate the values automatically. Key
    Frames are set automatically when you edit the value in the input
    ?eld causing an animation curve to appear in the Graph Editor
    curve window and a tick mark to appear in the timeline area of Effects mode. You can
    move existing key frames in time by dragging the tick mark in the timeline area. For
    more precise control of parameter automation, use the Graph Editor.

    Parameter Scripting Mode (expression)

    This mode uses value input that is generated dynamically by effects such as Trackers or
    TCL script expressions. This avoids the need to save and load static graph data in Graph
    mode. Syntax for script mode is simple: for example, if the Tracker was set to export the
    variables TX for the x axis and TY for the y-axis, the effect receiving the exported variables
    would have a $ placed in front of each variable. So TX and TY will now be $TX
    and $TY in the effect where the data is to be used.

    dragging parameter labels

    At any time while you are editing an effect with input ?elds, you can interactively adjust
    the value by dragging on the label for the input ?eld. When you have achieved a value
    that is acceptable, simply release the mouse button. The effectiveness of this mode is
    also dependent on the size of the layer, the proxy level that you are working at, and the
    nature of the effect. For example, a blur effect on a 2K layer will not be interactive unless
    you are working at a high proxy level such as 4 or 8.

    The Graph Editor

    The application's graph editor is a powerful feature that allows precise control and editing of

    animation curve data. The layout of the graph editor consists of the channel list on

    left, the main graph area, and an info and command line area at the bottom of the view.

    Individual channels can be toggled off in the view by clicking on the channel list items.

    Zooming and Panning the graph

    To pan in the graph, simple click and drag using the middle mouse button.

    To zoom in, hold down the z and left mouse button.

    To zoom out Hold down the z and middle mouse.

    To select points, click and drag the mouse around the point or points that you want
    to select and modify.

    Stereo 3D

    The Piranha Stereo option provides the ability to display, edit
    and apply effects to stereo content.

    Configuring Stereo

    The Stereo option panel in Piranha's System Preferences provides
    the necessary controls to get started.

    Stereo Display
    The Stereo Display control chooses the stereo hardware that will
    be used by the program.
    Options are:

    Nvidia Driver For hardware requiring nvidia driver
    support - shutter glasses, multiple projector
    Interlaced Monitors such as Hyundai, JVC, Miracube and Zalman
    Checkerboard Monitors such as Mitsubishi DLP
    Anaglyph Red/Cyan The Red/Blue glasses
    Anaglyph Magenta/Green The green and purple glasses

    Startup Default
    This option chooses whether the app will begin in stereo or 2D mode when its started.

    Pattern (int/check)
    Controls whether left and right should be swapped for checkerboard and
    Interlace modes.

    Using Stereo

    The first step in using stereo is to assign a layer as being Left Eye,
    Right Eye or Both. To do this simply select a layer or a series of layers
    in the Edit timeline and the hold down the right mouse button to access
    the layer menu. (you can also click on the Layer menu at the top of the

    Once you have some layers setup, Stereo can be toggled on and off by
    clicking on the 2D/Stereo menu on the left side of the interface.

    Using the Stereo Panel

    The Stereo panel (choosable at the bottom of the interface window) provides
    for basic controls over left and right layers.

    Convergence controls the distance between the Left and Right eye images
    in X axis. The percentage of displacement is shown next to the control
    value which represents pixels.

    The Camera convergence control controls the separation on layers which
    are being moved in 3D space.

    Vertical convergence on left right layers.

    Auto Level
    Autolevel attempts to match White and black points by comapring
    and setting dGain and dBias controls

    Gain and dGain
    Gain controls both layers gain, dGain contols only the difference
    between the two layers.

    Bias and dBias
    Gain controls both layers gain, dGain contols only the difference
    between the two layers.

    Rot and dRot
    Gain controls both layers gain, dGain contols only the difference
    between the two layers.

    Auto Scale
    Autoscales to fit for any overlap betwen layers caused by
    convegencen adjustment

    Scales all the layers

    Moves all the layers in X

    Moves all the layers in X

    Stereo Analysis Tools

    Both the Wavefrom monitor and Vectorscope
    (found under the Tools menu) can provide
    stereo difference information in their readouts.

    This allows for easy scope based matching of
    left and right images.

    Piranha's Stereo Flow Effects

    The stereo flow toolkit provides some amazing tools
    for both Stereo Correction as well as Stereo Conversion.

    Overview of Stereoflow Effects

    The stereoflow effects have several common parameter controls.
    These include Horizontal pixel offset, Vertical pixel offset,
    and Profile Graph. The Profile graph or Flow graph is especially
    useful in its ability to allow 3D to be shaped using a profile.

    Alpha Mover Takes Alpha Channel (from Color effect Keyer output)
    and moves those pixels only
    Layer Mover Takes alpha channel from another source layer (maya depth image)
    and moves those pixels only
    Alpha Flow Takes Alpha Channel (from Color effect Keyer output)
    and warps those pixels
    Layer Flow Takes alpha channel from another source layer (maya depth image)
    and "warps" those pixels only
    Halo Flow warps the image around a specified point. Graph controls warping falloff or distance profile
    Roto Flow warps the image using a Rotospline
    Back Flow Quickly adds depth by ramping by vertical position. Graph controls the actual depth profile of the background

    Color Correction

    To get started color correcting in Piranha, have a clip loaded and
    go to the Color tab at the bottom of the interface.

    Once there, click on the "Add Color" button


    The Curves panel provides RGB, Value, Hue, and Saturation curve adjustment.

    Corrector Wheel Controls

    Corrector wheels provide control over
    Shadows/Midtones and Hilites


    Areas affected by the color correction can be controlled by
    both the Keyer and the Roto tools


    The Keyer allows a single color or range of colors
    to be selected.

    Rotoscope based Masking for Color

    The rotoscrope interface provides quite a bit of controls
    over the area of correction (often called a window on
    some systems)

    Once enabled find the roto controls at the bottom of the canvas.

    To draw a roto shape simply click and position points
    where needed. If you are using Bspline points the 1,2,3 keys
    set curve tightness.

    To adjust the softness of a spline shape
    hold down the Alt-Key while clicking inside the shape.
    You can also open the roto menu with the right mouse button
    and choose Set Softness.

    Creating Complex Shapes

    The roto tools support negative shapes fore make holes and other
    complex shapes. To make a shape negative select it and
    hit the '-' (minus) key. The shape will turn Red
    as seen below.

    Controlling the Mask

    Switching the viewing mode from RGB to Matte allows us to see
    what is happening with the matte/mask channel.

    By selecting the Mask channel in the curves control
    the falloff of the matte edges on keys and rotos can
    be adjusted.

    Keeping Track of changes

    When a change is made in the color tools
    a small blue dot will appear next to the
    parameter. Clicking on the dot to
    change it back. Also most parameters reset
    to their default value when you hold Alt-key
    and click on their label name.

    The Analysis window is another way to see what has changed.
    The graph shown shows how your curves are changing due
    to the many color settings you have in use. (r/g/b/a curves
    + gamma, scale, and bias.

    Scopes and More Scopes

    For Monitoring color Piranha has both a vectorscope and waveform monitor
    availble under the tool menu.

    The Waveform monitor shows Y+Chroma by default.
    This can be switched to RGB Parade mode by selecting
    from the menu. Note if the mode is set to Region
    you will only be scoping a small area under the
    scope, make sure to switch to Setup to see the
    full visible area.

    Copying Effects

    Effects can be copied by holding down the right mouse button over
    the effect name and choosing "copy". To copy a single effect
    to multiple clips, just switch to edit mode, select all the clips
    hold the right mouse button down and choose "Paste Effect" or "Paste Effect Into".
    Paste Effect Into has the added advantage that it will "replace" any
    effect which has the same name. (good to avoid multiple copies
    of the same effect)

    Renaming Effects

    Your color effects can be given any name you like.
    Just double click the name text in either the color panel
    or effects mode to edit.

    Sharing Effects

    Effects can also share values. By holding the right mouse button down over
    an effect and choosing "Share" the effect will become global.
    What this means is that any other effect with the same name
    will share values with this effect. So change one, change them all.

    Createing a Look Bin

    A final way to move and share effects is by creating a "Look Bin".
    This is done by creating a directory in the clip bin and dragging
    effects to it. To create a directory in the Clip bin
    navigate to a place you have write permissions and choose
    "Create Directory" from the Clip Bin's File menu.
    To drag effects simple click on the effect icon or name in
    the color panel and drag to the clipbin.

    To add a look to a layer simply drag the look
    onto the layers clip icon.


    Piranha hardware accelerated particles open the door for a whole new level of image
    synthesis. Completely 3D, texture mapped and motion blurred, particle effects are fast
    and interactive, allowing the user to move generators and adjust particle parameters in
    real time while the system animates. Particle systems can make use of both image
    trackers as well as audio trackers for controlling parameters.

    Advanced effects such as generating particles on the surface of imported 3D geometry as
    well as full collision detection with any other 2D or 3D layer in the system are possible.
    You can do this by using the OBJ Read with the Layer Generator and Collision effects.

    Point Generate Effect

    The Point Generate particle tool launches scaled copies of the layer image from a single
    point in three-dimensional space.


    The position of the emitter from which the particle images are launched.


    The size in pixels of the emitted images. The layer image is scaled to a square aspect

    Num Particles

    The number of particles emitted per frame


    The lifespan of the particles in frames. After the speci?ed lifespan has elapsed, the
    particle will be removed from the canvas.


    The velocity of the emitted particles upon emission, in World Space units per frame.


    The Drag value speci?es a braking force to slow the particles after launch.

    Layer Generator Effect

    The Layer Generator tool launches particles off the geometry and color of a source layer.



    Particles emitted are white, regardless of the layer color, and are emitted at
    random places on the surface with no relation to image data.


    Particles emitted are the color of the reference image.

    Image No Black

    Particles emitted are the color of the reference image, with no particles emitted
    for true black (RGB 0,0,0) pixels.

    Image As Tiles

    Particles emitted are cutouts of areas of the reference image, relative to the Size
    attribute described below.

    Layer Selector

    Selects the layer to use as reference for image and geometry. If the layer contains an
    OBJ Read effect, particles will be emitted from the surface of the 3D object in the
    direction of the polygon normals.

    Num Particles

    The number of particles to be emitted per frame.


    The initial velocity of particles upon emission.


    The deceleration in units per frame to slow the velocity of emitted particles.


    The size of the emitted textured polygons.


    The lifespan, in frames, for each particle. When this amount of time from emission
    elapses, the particle is “killed” (e.g. removed from the workspace)

    Particle Rotate

    The Particle Rotate effect will rotate a particle both randomly or in unison.
    You will need to use an image particle effect or 3D model particle to see this effect.



    Random rotation about all three axes.

    Use Axis

    Rotate around axes in a ratio speci?ed in X, Y, and Z.


    De?nes the degrees of rotations per frame.

    Environment Effect

    The Environment effect allows for particles to be controlled by a global gravity and wind

    Wind Direction

    The direction represented by a three-axis rotation vector in which the particles will be

    Wind Speed

    The speed in World Space units per frame that the particles will be moved.


    This speci?es a downward force applied equally to all particles.

    The Floor Effect

    The Floor effect provides a simple and fast way to make particles bounce or roll when
    they reach a given Y location.

    Y Position

    The distance from the World Space origin to place the Floor plane.

    Floor Flex

    The resilience of the Floor, like a rubber mat, will make the particles bounce upon

    Floor Friction

    The damping factor applied to particle motion upon collision wiith the Floor.

    Collision Effect

    The Collision effect causes particles to react to another image layer by either avoiding it
    by a set distance or by bouncing off the surface. Surface attributes for collision layers
    include surface ?exibility and friction. Collision layers, like Layer Generators, can have a
    variety of geometry and warping effects applied.

    Source Layer Selector

    Here is selected the layer with which the particles will collide or avoid.


    The resilience of the Collision object, like a rubber mat, will make the particles
    bounce upon collision.


    The minimum distance in World Space units that particles will seek to keep between
    themselves and the Collision object.

    Particles Effect

    The Particles effect was previously required to make a layer

    animate as a particle system.

    The Image Particle Effect

    The Image Particle effect allows for particles to have an image sequence or the layer
    image which plays asynchronously relative to the layer image (e.g. per-particle trans-
    forms and effects). Normal particle behaviour is to put the layer image with the same
    (present) frame on all particles; with Image Particle the clip will start at the time of
    emission. This effect can also be used with OBJ Read to have object instancing function-
    ality, where the geometry loaded from a ?le is used for the particle instead of the default


    Sets the image drawn on the particles to be either the Layer Image or an image
    Sequence from a ?le, selected below.


    If Loop is enabled, then the particle image sequence will be repeated until the death
    of the particle.


    Sets the display blending of the particles.

    Z Sort

    If enabled, this will display the particles with correct 3D overlap with Composite set
    to Over. Slows down calculation slightly.


    Click on this box to bring up a ?le browser for selecting the image sequence to
    display on the particles. A reduced-resolution proxy will be rendered to your Vault.

    Magnet Effect

    Fade In/Out

    De?nes a fade length (in frames) for particles.


    The Magnet effect creates a point attractor for particle systems.


    Sets the position of the magnet attractor in world space.


    De?nes the radius of the attractor point. Smaller radii contain the same Gravity in a
    smaller area, and hence pull on the particles more strongly.


    De?nes the strength of the attractor point.

    Blender Effect

    The Blender Effect provides some compositing control for how image particles are blended.

    Working with Red Content

    Red Camera Files or R3D files work in the system
    a little differently than other file formats.
    Because they have the ability to trade speed for
    detail, they offer a nice workflow for systems without
    fast diskarrays. Also because they have 16bits
    of color depth, they really provide the artist with
    some amazing color capabilities.

    Browsing Red Files in the Clipbin

    One of the more difficult tasks in browsing
    through Red Camera data is that each shot is actually
    a directory.


    Having to repeatedly descend into each directory to look at
    an icon can be time consuming. To solve the problem,
    the app actually shows the B005_C001_032444.RDC as the
    top level clip.

    Working with Quality vs Speed using Proxy Menu

    Red Files all have multiple quality levels that can be
    used to trade speed for resolution. To select the current
    quality level simply pick the Proxy level from the View menu.
    Proxy levels 8 and 16 will playback in realtime.
    Switch to full res or proxy 2 to check 4K and 2K.

    Red Camera Data and the Red Light Effect

    The Red camera doesnt actually change any pixel data
    when recording in Raw mode. Instead the settings of
    the camera are simply saved and then used during the
    reading process.

    To view and adjust camera values on a layer you
    can add the Red One Light Effect
    (Add Effects --> Plugins --> Red One Light)

    Red Global App Settings

    Under the Plugin menu there is also a Red Camera settings
    panel that can be brought up. This has some global settings
    that can be used to used to optimize reading or improve quality.


    One of the most powerful features of Piranha is its rendering

    Piranha can render to a variety of formats as well
    as aspect ratios

    The render controls can be accessed by choosing Render from
    the File menu.

    By defualt Piranha will render to your setup resoltion.
    (See File::Setup) you can change the resolution
    and aspect ratio from the controls on the top
    half of the interface.

    Piranha can render to a variety of formats, the default format
    is the IFX Arc format which is an uncompressed RGB
    file format.

    Choosing "File" as the Output will show
    the settings for exporting a sequence of
    files such as DPX, TIFF TGA and others.

    If your system has quicktime installed the Quicktime
    rendering options should be accessable from the

    Learning More about Piranha

    Hopefully you have a good basis now for exploring the application
    further. This document really just scratches the surface of some
    of the features and capabilities of the Piranha system.

    Thanks for reading!